Jump to content

Problem with VIPM for linux


Recommended Posts

Hi, my name is Francesco. I'm Italian and i don't speak good english. 

I have a problem with the installation relatives VIPM in linux

I follow the instruction but appear this message when i launch the command: sudo ./vipm

Can't find library liblvrt.so.15.0
Make sure this library is installed in your LD_LIBRARY_PATH
search path, or in /usr/lib
To download the LabVIEW Runtime engine, go to http://www.ni.com/rteFinder?dest=lvrte&version=15.0&platform=Linux&lang=en
How can i resolve this?

Thank you so much and sorry for my english!

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 months later...

Hi Jim

I have a Centos 7 and Labview 2018 installed

I install VIPM, however I received the same error as Francesco. I'll try to install the LVRT engine, but I received the following errors (even if it is in italian, it is simpleto understand what happens...)

sudo ./INSTALL (or with su privileges, is the same...)

Preparazione in corso...              ################################# [100%]
Aggiornamento / installazinone...
   1:labview-2015-rte-15.0.1-11       ################################# [100%]
Preparazione in corso...              ################################# [100%]
Aggiornamento / installazinone...
   1:labview-2015-rte-32bit-15.0.1-11 ################################# [100%]
Preparazione in corso...              ################################# [100%]
    il pacchetto nisslcerts-18.0.0-3.0.noarch (il quale risulta essere più recente di nisslcerts-15.5.0-3.1.noarch) è già installato
Preparazione in corso...              ################################# [100%]
    il pacchetto nissli-18.0.0-f0.i386 (il quale risulta essere più recente di nissli-15.5.0-f1.x86_64) è già installato
    il pacchetto nissli-18.0.0-f0.x86_64 (il quale risulta essere più recente di nissli-15.5.0-f1.x86_64) è già installato
errore: Dipendenze fallite:
    nissli-32bit < 16.0.0 reso obsoleto da (installato) nissli-18.0.0-f0.i386
    nissli-32bit < 16.0.0 reso obsoleto da (installato) nissli-18.0.0-f0.x86_64
errore: Dipendenze fallite:
    nicurli >= 18.0.0 necessario a (installato) ni-visa-lxi-discovery-18.2.0.49152-0+f0.x86_64
    nicurli >= 18.0.0 necessario a (installato) ni-wsrepl-18.1.0.49152-0+f0.x86_64
    nicurli >= 18.0.0 necessario a (installato) ni-488.2-sysapi-support-18.0.0.49152-0+f0.x86_64
    nicurli >= 18.0.0 necessario a (installato) ni-visa-lxi-discovery-18.2.0.49152-0+f0.x86_64
    nicurli >= 18.0.0 necessario a (installato) ni-wsrepl-18.1.0.49152-0+f0.x86_64
    nicurli >= 18.0.0 necessario a (installato) ni-488.2-sysapi-support-18.0.0.49152-0+f0.x86_64
errore: Dipendenze fallite:
    nicurli-32bit < 16.0.0 reso obsoleto da (installato) nicurli-18.0.0-f0.i386
    nicurli-32bit < 16.0.0 reso obsoleto da (installato) nicurli-18.0.0-f0.x86_64
errore: Dipendenze fallite:
    nisvcloc < 18.1.0 reso obsoleto da (installato) ni-service-locator-18.1.0.49152-0+f0.x86_64
Preparazione in corso...              ################################# [100%]
    il pacchetto nitdmsi-18.0.0.49152-f0.i386 (il quale risulta essere più recente di nitdmsi-15.2.0-f0.x86_64) è già installato
    il pacchetto nitdmsi-18.0.0.49152-f0.x86_64 (il quale risulta essere più recente di nitdmsi-15.2.0-f0.x86_64) è già installato
errore: Dipendenze fallite:
    nitdmsi-32bit < 16.0.0 reso obsoleto da (installato) nitdmsi-18.0.0.49152-f0.i386

Installation completed.

and then

sudo ./vipm
Can't load library /usr/local/lib/liblvrt.so.15.0
libXinerama.so.1: cannot open shared object file: No such file or directory
To download the LabVIEW Runtime engine, go to http://www.ni.com/rteFinder?dest=lvrte&version=15.0&platform=Linux&lang=en


what can I have to do?

 

dh

 

 

 

Link to comment
Share on other sites

  • 5 months later...

I appear to have a similar problem to that of Francesco and Dariush with initially starting VIPM for Linux.  I am using CentOS 7 in a VirtualBox VM.  I have LabVIEW 2018 SP1 installed and working and want to use VIPM to manage some of the add-ons that I want to use with LabVIEW.  The problem is, even though I am signed in as root, when I execute the recommended command to start the installation of VIPM I get the system response "sudo: unable to execute ./vipm: No such file or directory".  This seems to be indicating that I am missing some dependencies that would recognize the vipm file as an executable, but I haven't seen any comments here or anywhere else that provide the missing information I need to make this work.

Here's a screen snippet showing the directory contents and the terminal window showing the command and response I am receiving:

image.png.e9fe5be5ebf94abe0337559da9e07b6e.png

Any ideas how I can get vipm working here?  BTW, I am using the latest version of VIPM for Linux that I could find, extracted from the archive vipm-17.0.2018-linux.tar.gz.

Regards,

Bill

I was successful at getting this to work after following the directions that Jim posted in the previous message - I needed the 32 bit libraries for CentOS.

See image below:

image.png.4f0947cdc4b1802fd418c1d5329c9dd6.png

 

image.png

Edited by Bill_in_Detroit
New information
Link to comment
Share on other sites

  • 1 month later...
On 9/26/2019 at 7:00 PM, DavidLee1997 said:

Having followed all of the above suggestions, I am still unable to open VIPM.  When I run the command "sudo ./vipm" I get an error "Unable to open X display".  I am using openSUSE 15.1, and trying to use VIPM 2017 with LabVIEW 2017.

Any suggestions on how to run this one down?

Thank you!

Hi David. I don't any ideas about how to get around that. Have you tried posting to the LabVIEW Linux Users group?

  • Like 1
Link to comment
Share on other sites

On 9/26/2019 at 10:00 PM, DavidLee1997 said:

Having followed all of the above suggestions, I am still unable to open VIPM.  When I run the command "sudo ./vipm" I get an error "Unable to open X display".  I am using openSUSE 15.1, and trying to use VIPM 2017 with LabVIEW 2017.

Any suggestions on how to run this one down?

Thank you!

This may be due to the Wayland X server. If you are using Wayland, try switching to the Xorg X server and see if the command works.

  • Like 2
Link to comment
Share on other sites

All-

Thank you for your responses.  I will post the question on the NI LabVIEW Linux Users group, and I will also verify the X server that I am using, changing to Xorg if necessary.  I will post the updates here and in the NI user group.

On a side note, I switched the VM over to CentOS7, and I have been able to install and run VIPM using the above link to the additional packages.

Link to comment
Share on other sites

On 10/2/2019 at 11:52 AM, spookievision said:

This may be due to the Wayland X server. If you are using Wayland, try switching to the Xorg X server and see if the command works.

First, I confirmed that the CentOS VM is using Xorg.

Using the openSUSE VM, I confirmed that the default x server is Xorg (echo $XDG_SESSION_TYPE responds with x11).  I was unable to launch VIPM (unable to open x display).  Changing over to Wayland, I again received the same error message.

I will be posting this update over in the NI forums, in the Linux Users group.  Again, if anyone has suggestions, I would appreciate them.

Link to comment
Share on other sites

On 10/8/2019 at 11:28 AM, DavidLee1997 said:

First, I confirmed that the CentOS VM is using Xorg.

Using the openSUSE VM, I confirmed that the default x server is Xorg (echo $XDG_SESSION_TYPE responds with x11).  I was unable to launch VIPM (unable to open x display).  Changing over to Wayland, I again received the same error message.

I will be posting this update over in the NI forums, in the Linux Users group.  Again, if anyone has suggestions, I would appreciate them.

I missed the part where you are using a VM for this. Are you accesing from a remote X session? If so, the root user will require some additoinal authorization to run GUI based applications in remote sessions.

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
  • 1 year later...

Hello, I managed to install LV2020, and VIPM 2017 on Ubuntu 20.04. They both work well, but I am experiencing issues with the fonts in VIPM (some of the fonts are Chinese and they are very ugly).
LV2020 works well. I assume it is related to LV2015RTE.
Do you see the same in OpenSuse Leap 15.1?

image-fonts.PNG

Edited by Marco Pignati
Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.