Jump to content

VIPM 2020.3 (build 2529) for Mac can't install "NI Current Value Table" package

Recommended Posts

Within VIPM I click on a package, then Install.  A VIPM - VI Package Manager Window pops up with License agreement.   I click on the Yes I accept… button, then nothing happens and I eventually have to force quit VIPM. I've tried this several times with the same result.



Admin Update: This issue's root cause is that VIPM 2020.3.2529 for Mac was having problems with packages containing files marked as read-only AND also having trouble with files inside the package that had brackets [ ] in their filenames. This will be fixed in the next build/release.


Edited by Jim Kring
Changed post title to more accurately reflect the bug
Link to post
Share on other sites

Thanks, Greg.

It appears that there's a lot going on -- the first issue seems to be that the native LabVIEW HTTP Client is having trouble dynamically loading a DLL (and it's probably a LabVIEW runtime related thing). It also seems to be some file permissions issues writing to temp files.

I'll mention that our focus with VIPM 2020.3 has been getting things working well in 64-bit macOS like Mojave and Big Sur.

What did you upgrade from 2020.1, 2017.0, other? (BTW, you can download older VIPM versions here)

Link to post
Share on other sites

Also, I've been working to share (as an open source project on github) the command-line zip/unzip tools (for Mac and Linux) used by VIPM.

The project is here:


Would you be able to download these and try them out? I went through the effort to create a high-level test VI that exercises all the core functionality.


As I was making this, I did try running it on Big Sur and got an Error 10 when trying to Create Dir if Exinsistant.  I replaced this with a call to the LabVIEW built-in utility Create Directory Recursive and it resolved the error. I've already made that fix and pushed it to the github repo.

Note: It seems this issue has to do with macOS tightening the permissions in the temp folder to prevent listing the contents of directories inside the temp folder. This probably aims to make it so that only the creator of files/folder can work with them.

Link to post
Share on other sites

I need to be able to download the OpenG File library to test anything you've requested of me, but the download requires my email address & password.  I just created an account yesterday, but the site is not taking my password.  I've tried repeatedly to reset my password but I never receive an email for the verification link.  Help!

Link to post
Share on other sites

I was able to download the OpenG File library from within VIPM (instead of through a web browser) and interestingly it installed beautifully.  The package that I am having problems installing is "NI Current Value Table".  I deleted the local copy of that package and then downloaded it again from within VIPM and tried to install it.  Same problem - I can't get past accepting the license.  It seems they may be something wonky with the"NI Current Value Table" package, VIPM 2020.3 and LabVIEW 2019 SP1 on a Mac.

Link to post
Share on other sites

I ran your Read License Agreement Text.vi as you instructed.  It displayed the License Agreement Text for 'jki_lib_rest_client-' and it ran without error.


Also, the command-line zip/unzip tools (Test Zip and Unzip.vi) ran without error on my Mac (Catalina 10.15.7 (19H15)) and LabVIEW 2019 SP1.

Now if I can only install the Current Value Table package...



Link to post
Share on other sites

Oh, that's great news that you were able to get a bit further.

Also, I'm (thankfully) able to reproduce the issue with the NI Current Value Table Package (it get's stuck, as shown below, just as you described).

I'll dive deeper into this and see if we can find out what's going on.

Thanks again for helping test this out and for your patience.



Link to post
Share on other sites

You're very welcome, Greg.

So, it turns out the NI Current Value Table package has not one (1) but two (2) interesting things inside it that cased the command-line zip approach to choke (and I'm working on fixes):

Issue 1) The license file is marked inside the package as READ-ONLY. This happened when the package was build, because the file was READ-ONLY in the developer's source folder.

Issue 2) The package has files with brackets "[" and "]" in the filenames and the command line shell was not handling them unless they were escaped as "\[" and "\]".

I've filed a couple bugs and am working on a fix. Hopefully, we'll get a build of VIPM for Mac that can handle this package.


Love VIPM? Don't forget to consider VIPM Pro licenses for you and your colleagues while the 2020 Cyber Monday sale is going on ;)


Link to post
Share on other sites

Hey Greg,

I've got a new build for you to test.

vipm-20.3.2537-mac.zip (this link may stop working in a day or two, as we're working on an official release)

This should fixe both issues:

  • read-only files inside the package
  • packages containing files with brackets "[ ]" in their filenames

Please try it out and let me know how it works for you.


Link to post
Share on other sites
  • Jim Kring changed the title to VIPM 2020.3 (build 2529) for Mac can't install "NI Current Value Table" package

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.