Jump to content

vipm opens with labview. necessary?

Recommended Posts

Hi there.

A couple things:

1) There is a way to disable this in the settings file.

2) We just released 2020.3 (SP3) that disables the system tray by default, which will also prevent automatic start when LabVIEW starts.

My suggestion would be to go with #2 so you're running the latest and greatest version of VIPM, since it has some other improvements, too.

Please let us know how that works for you.



Link to post
Share on other sites

I did update to 2020.3.  VIPM opens when I run LabVIEW 2019 but not when I open LabVIEW 2020.

Also, I couldn't find any version info in the options menu of VIPM to make sure it did update to 2020.3 after restarting.  However, when I run VIPM by itself, it shows 2020.3 in the opening screen.

This is no VIPM system tray on my Windows 10 computer.


Edited by rrd2
more info
Link to post
Share on other sites

Oh, I think I know what it is. The service that auto-starts VIPM looks for the transition from NO LabVIEW versions running to ANY LabVIEW version running.

Here's what I think happened:

  1. LV2019 started, which auto-started VIPM.
  2. VIPM was closed and LV2019 was left running.
  3. Then, LV2020 was opened (while LV2019 was still running)
  4. VIPM did not auto-start because the transition from NO LabVIEW running to ANY LabVIEW running did not occur.

Anyhow, it's not super important, since we'll fix this, but I hope it's helpful to make sense of what was happening.

Link to post
Share on other sites

I understand and I don't mind helping improve great products like yours.

When I started the day yesterday, I opened LV2020 to work on one project.  Upon completion, I closed LV2020.  A few hours later, I had to work on another project that used LV2019.  That's when VIPM opened and I closed immediately closed it.  Finished my work in LV2019 and closed it.  Later I had to open it again and VIPM opened along with it again.

This morning during our initial messages.  I opened LV2019 to make sure I was correct in my replies.  I then close it and opened LV2020.  That's when I noticed no VIPM.  Closed LV2020, opened LV2019, and ... TA-DA ... VIPM.

Hope this helps.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.