Jump to content

Recommended Posts

Hello,

I was using VIPM 2019 and Labview 2019 without issue.

After update to Labview 2020 and VIPM installed directly with NIPM, VIPM has error when launch.

If I downgrade to VIPM 2019, it works but I can't link with Labview 2020.

I tried to install VIPM 2020.1 and 2020.2, 2020.3 with NIPM or directly but still the same issue.

There is no error in C:\ProgramData\JKI\VIPM\error

Thanks

VIPM_2020.3_error.PNG

Link to post
Share on other sites

Hello, I have been too much optimistic. Finally IT can't disable the antivirus on my computer for a long time.

They whitelisted the C:/program files(X86)/JKI folder without effects.

Do you know if there is some dependency or some others folders we could try to whitelist?

thanks.

Link to post
Share on other sites
  • 3 weeks later...

Hello @Sam Grayson and @Jim Kring, the IT departement tried to whitelist any folders but it didn't work finally. it was working few time if VIPM start before Cyberreason.

Anyway IT solved the issue with puting my computer in a special group to only use antivirus of cyberreason. Now it works correctly.

I try to get more information from IT departement and let you know when I have news.

  • Like 1
Link to post
Share on other sites

@Jim Kring @Yann Report from my adventures with IT.

Short term solution: We found that it was the Cybereason ActiveProbe service that caused the run error. If that service was disabled, VIPM can launched without issue.

Long term solution: IT assigned a policy to my machine that disabled some Cybereason monitoring for .NET (they were vague). I was then able to use VIPM while ActiveProbe was running.

That's as specific as they were willing to get. Hope this helps!

  • Like 1
Link to post
Share on other sites
  • 4 weeks later...

We are also having issues with VIPM not running on our development computers due to Cybereason ActiveProbe. But it's even worse for us...

We have LabVIEW 2019 Runtime in our Software Center, which allows anyone in the company to install it without admin rights. This has been done so we can give small executables to people to use, ones that don't need VISA, DAQmx, etc. Runtimes. Well, everything was fine a couple weeks ago but now ALL of those small programs load up with the same message, "The VI is not executable..."

Since VIPM 2020 uses LV19 Runtime, this makes sense. But wow is it a pain. We're also in talks with IT as to what the core issue is and what course of action to take.

Link to post
Share on other sites

Oh no! I’m sorry to hear the installers and security challenges are such a pain.

I wonder if there’s a way to have a VIPM installer that does not include the runtime engine stuff — can you install VIPM and the skip over the runtime installer part, I wonder.

Link to post
Share on other sites
  • 2 weeks later...

I have the same issue. New computer and fresh installation of the Windows OS. After installing LabVIEW 2020 and restarting the computer, the same information (VIPM service with dashed arrow) as at the beginning of this post appears . I did try also earlier versions of VIPM. It works well up to v. 2019. Problems started after upgrade to 2020.1 ol later versions.

BTW. I have Cybereason installed too.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.