Jump to content

SQLite Library installation to lv-venv folder issue


kosist
 Share

Recommended Posts

1. Created LV project, added empty VI.

2. Created new Dragon project, selected above created project.

3. Opened Resources tab, Add Package -> SQLite Library in lv-venv folder.

4. Started installation.

5. Installation gets stuck on "Reading VI Linker" operation. But, toolkits are shown as Installed in VIPM window.

image.thumb.png.d2e3f5248d024d15f419c9515e014592.png

6. Pressed button "Cancel" in small VIPM Handler window -> window was simply closed.

7. Pressed red round "Abort current operation" button in VIPM window -> button disappeared.

image.png.1fea32d7b48b9701397ac49cd14d226d.png

8. Closed Dragon window -> it was simply closed, but VIPM remained opened.

9. Had to kill VIPM process via Task Manager.

10. Reopened Dragon project again, and opened VI in the project.

11. Checked functions menu palette. SQLite menu entry is there, but no VIs are loaded:

image.png.f782fe3b3a0ce6a018b4ccdcc3416937.png

12. Inspected lv-venv folder on the disk -> VIs are present on the disk.

13. Tested this behavior in LabVIEW 2020 and LabVIEW 2017 - result is the same.

14. Tried to install SQLite Library into global environment via Dragon -> everything works fine.

15. Tried to install some another toolkit locally (OpenG Boolean library) - everything works fine.

Maybe, it is issue just of SQLite Library toolkit, but for sure there is something not OK overall - somehow VIPM gets into the state when it is not responsive, and one has to kill it via Task Manager.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.