Jump to content

VIPM Package Build Problem

Recommended Posts

VIPM 2020.3 (build 2540)

I'm getting a bizarre error. I get a build failure where VIPM claims that the following source library is missing

C:\Common\Generator Interface\Message Interfaces\Gen11 Message Interface\Gen11 Message Interface\Gen11 Message Interface.lvlib

When the library actually is located here.

C:\Common\Generator Interface\Message Interfaces\Gen11 Message Interface\Gen11 Message Interface.lvlib

This library is a collection is actor message interface classes if that makes a difference. I'm also been able to do a mass compile of the entire directory without any errors.


This might not be related, or a quirk of the builder that I don't know about: The other weird thing is if I open the project while VIPM is in the failed state, the error list contains a bunch of failed VIs that couldn't find a .NET library located within my project.

(This project is pretty big and contains some proprietary information so I can't upload it. Sorry, that makes it hard to troubleshoot.)


  • Upvote 1
Link to comment
Share on other sites

Does the VIPM error dialog state which calling VI is trying to find that missing VI?

The dialogue has two parts: one that shows you the missing VIs, and the second that shows you which project source VIs are calling the missing VIs

also, often the culprit is a VI on disc that is not actually being used anymore, but it’s broken. The package builder is including it, even though it’s not being called by anyone

  • Upvote 1
Link to comment
Share on other sites

This is the first window that pops up



Wouldn't a mass compile of the directory ferret out any broken VI's that are looking for a library in the wrong place? Does this mean I have an external dependency doing this?

Link to comment
Share on other sites

Thanks for posting the screenshot. What does the dialog show after you press OK? It should indicate the caller of that missing vi.

it’s hard to know for sure if A mass compile of your Source folder would fix the issue. Possibly, yet sometimes the linkages can be crossed up across different projects.

  • Upvote 1
Link to comment
Share on other sites


Those are classes within the library.

If I open up that library, it shows no errors. If I open up those message classes, they open up the library fine.

I just tried to open the library and do a save all. Still getting the error.

Link to comment
Share on other sites

On a whim, I decided to try and delete the lvlib and rebuild a new one (they weren't that complicated). That seems to have solved the problem.

Some sort of corruption? (although looking at the file in Notepad++, I'm not sure where that could have possibly gone wrong)


Either way, thanks a lot for the help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.