Jump to content

Error 1003 occurred at Invoke Node in JKI SDP.lvlibp:Start.vi


Recommended Posts

When I've installed and activated "JKI Design Palette", everything worked. But then, on LabVIEW restart, the following error occurs, and I can't launch the pallete.

What could cause this issue please? Could there be something missing? Because VIPM does not show any missing dependencies...

Also, I use the latest build of "JKI Design Palette", and LabVIEW 2017.

Thanks a lot in advance,

Sincerely, Ivan.

JKI pallete error.png

  • Upvote 1
Link to comment
Share on other sites

Hi Ivan,

Thanks for testing. Sorry it's not working for you.

I wonder if it's a permission issue, like maybe it was installed with VIPM Running as Administrator (with launched and ran LabVIEW as administrator) and the installed files are no longer accessible to LabVIEW after restart and no longer running as administrator.

Which version of Windows are your running?

What happens if you uninstall and then re-install DP?

Can you install older versions DP?


Link to comment
Share on other sites

  • 3 weeks later...

Dear Jim,

sorry for replying so late.

I use Windows 10; and I beleive that it is not related to user rights.
Actually, it works or not from time to time. Once I open LabVIEW - Design Pallete works; then I open some another project - it does not.
For example, I open new VI, and load Design Pallete. It works fine. Then I close VI, don't save it, and open project. Call Design Pallete again - it does not work, that error is dropped. I close project, open empty VI, call Pallete - still error occurs. I close LabVIEW, start it again, open VI - Design Pallete works.
Could it happen, that there are some in-memory dependencies conflict? Maybe pallete can't be loaded because lvlibp loads its VIs with the same names, which are already in LabVIEW memory?

Upd: sometimes it works with the same project. Thus, most probably it does not related to dependencies...

Thanks a lot,

Sincerely, Ivan.

Edited by kosist
Link to comment
Share on other sites

That's very interesting and odd. I haven't been able to reproduce this on my end, and I don't know if I've heard anyone else complain about this. I guess it could be due to some dependency. The JKI Design Palette is built into a PPL, so it should be pretty well isolated from such problems. When that happens, can you try opening the design palette manually (using File >> Open) and see if it's broken and if there's any useful information about why it won't run?


Link to comment
Share on other sites

Dear Jim,

I've tried to open it manually.
When I run Start.vi in the lvlibp, then the same error occurs.
When I open "JKI Design Pallete.vi", it is not broken. But when I run it, the following error occurs (Scan string error).
Also, I guess that this error causes LabVIEW crash (or, reason for LabVIEW crash is causing this error). I don't know, if dump file could help you, but let me attach LabVIEW crash report - maybe you could take a look on it please?

Error JKI Design Palette.png


Link to comment
Share on other sites

Hi Kosist. That sounds very odd. Somehow the "JKI Design Pallete.vi" instance that's running in the editor context (VI Server Application instance) is broken. I'm not sure how or why that would happen. Thanks for posting the dump file. It sounds like the LabVIEW crash means that something odd is happening under the hood of LabVIEW.

Does this only happen in LabVIEW 2017? Have you tried in 2018?

Link to comment
Share on other sites

  • 4 weeks later...
  • 10 months later...

Let me update this thread with new inputs.

I've found error logs for the toolkit (I guess this is some new feature). And it says the following:


=========== START of JKI Design Palette Error Message ===========
An internal JKI Design Palette Error has occured on: streda august 19, 2020 at 07:10:28 AM

= Automated Message Start = 
Error 59 occurred at JKI SDP.lvlibp:7731424720C9FF758CBFA6A64B4A0D4E.vi
Possible reason(s):
LabVIEW:  The network is down, unreachable, or has been reset.

Complete call chain:
     JKI SDP.lvlibp:7731424720C9FF758CBFA6A64B4A0D4E.vi
     JKI SDP.lvlibp:JKI Design Palette.vi
= Automated Message End =

= User Defined Message Start = 
    Main UI Unhandled Error
= User Defined Message End =

= Error Handler Call Chain Start =
    JKI SDP.lvlibp:JKI Design Palette.vi
= Error Handler Call Chain End =
=========== END of JKI Design Palette Error Message ===========

Which network it tries to reach? Could it cause that crash? I have active internet connection, so that should not be a problem...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.