Jump to content

VIPM not finding files in the correct place.

Recommended Posts

I am having an issue with VIPM build package not working correctly. It is telling me that I am missing files but it looking in the wrong place. See below for the example of what I am talking about. I have mass complied this directory to make sure that was not the problem. It just seems that VIPM is looking in the wrong place. I can open everyone of the files in the list and none of them are broken and none of them use the directory that VIPM is looking for. Thoughts?



Edited by TimE
Link to comment
Share on other sites

I was able to build the package that I sent yesterday. That seems to be working correctly now.

OK so I found a few issues:
- If the build file is not in the same directory as the code things go really bad. We do not keep the build files in the same folder as the code because is causes the revision control (SVN) to exponentially increase the data size. It seems that the .vipb files doubles every time we back up to SVN. the only way to stop that was to move if from the source file location. I'm not sure if this is a VIPM issue or SVN issue but the .vipb files seem to be the only file we have this problem with.
- We share the build packages between team members here. We are working to get all of our code in the same place on our computers but right now they may be off by one letter or something like that. When building a package from an existing build file. VIPM opens and the software path is not the same as the last time (I'm not sure where it get this directory from but it is never correct) It blows away my palettes. It is a pain to have to edit the icons and rebuild the palettes every time I do something with VIPM. It should maintain the pallets that were developed the last time it was built even if the source is not in the same place. I should get a chance to show it where the new source is before everything is blown away.
- I was adding the palette back once VIPM blew it out and went to edit the icon. It opened in LabVIEW 2023 before I realized this. I allowed it to open in 2023 then closed 2023 and tried to open 2024. The programs goes grey and never recovers from this. I have to kill the program to recover. Once I opened the icon editor in 2024 it worked as expected.

I am able to build packages now. Thank you for the update.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.