Jump to content

Recommended Posts

After starting VIPM 2019, I get an error when checking for updates: " there was an error accessing the following repositories:" LabVIEW Tools Network and VI Package Network. I have been using VIPM 2019 ever since it came out and have not seen this issue until now. I have checked for update and I am running the latest. I have checked with my IT guy and there is no web filtering that would be causing it not to get through.


Link to post
Share on other sites

=========== START of VIPM 2019.0.0 (build 2029) Error Message ===========
An internal VIPM 2019.0.0 (build 2029) Error has occured on: Monday February 10, 2020 at 07:10:23 PM

= Automated Message Start = 
Error 7 occurred at ZLIB Open Unzip Archive__ogtk.vi in OGPM 
Class.lvlib:5B2D78717A90673DBFEAD831BE8376F0->DEABCC9F97CF31105414B12209AD77A5->VIPM Main Window.vi
Possible reason(s):
LabVIEW:  File not found. The file might be in a different location or deleted. Use the command 
prompt or the file explorer to verify that the path is correct.
Nonexistent GPIB interface.
= Automated Message End =

= User Defined Message Start = 
    Error downloading from:  - http://ftp.ni.com/evaluation/labview/lvtn/vipm/index.vipr
= User Defined Message End =

= Error Handler Call Chain Start =
    VIPM Main Window.vi->
    OGPM Class.lvlib:5B2D78717A90673DBFEAD831BE8376F0->
    OGPM Class.lvlib:CAA36F9B6690452CF42DA4D8499D247D
= Error Handler Call Chain End =
=========== END of VIPM 2019.0.0 (build 2029) Error Message ===========

Link to post
Share on other sites

I've rebooted and even got latest windows 10 updates build 1909.

Not sure what you mean by "read the file".  When I click on the link it opens a tab and apparently a text file that begins with

"[Self]Self.Name=NI LabVIEW Tools Network Self.URL=file:///c:/lvtn Release.Number=2544 Release.Date=Wed, 05 Feb 2020 05:22:28 -0600 Self.ID=722df7e8e4010cd4570904b278388a7f Client.GlobalAccess=TRUE [Package abcdef_project_filter_and_edit-] Package.URL=packages/abcdef_project_filter_and_edit/abcdef_project_filter_and_edit- Icon.URL=packages/abcdef_project_filter_and_edit/abcdef_project_filter_and_edit- Spec.URL=packages/abcdef_project_filter_and_edit/abcdef_project_filter_and_edit- Package.MD5=d3b17d5964e33b4dc2bdb905e2200074 Package.Release Date=Thu, 19 May 2016 15:46:24 -0500 Platform.Exclusive_LabVIEW_Version=LabVIEW>=11.0 Platform.Exclusive_OS=Windows NT,Mac OS>=10 "

Link to post
Share on other sites

One thought I have is that you might try the Options >> Network >> Configure Proxy to Access the Internet setting.

Try testing VIPM with either "Use System Proxy Settings (Windows Only)" or "No Proxy (Direct Connection)" -- that can sometimes make a difference.   


PS - Your options page might look a little different, since I'm using VIPM 2020 beta. 😉

Link to post
Share on other sites
8 minutes ago, JKI-OfAllTrades said:

Yes, I checked that setting. I tried both settings. Both give the same error when refreshing

Shoot. That setting was my secret weapon. Now, I'm not sure what it could be...

If you're interested, you might try VIPM 2020 Beta and see if that fixes things. It's pretty stable at this point and we're actively fixing issues.

Link to post
Share on other sites

Another interesting observation:  If I choose Not Installed packages, I get a list of packages. Regardless of which package I choose, I get the following when I try to install it: "Package is not compatible with your operating system or any LabVIEW version installed..."  I am running Windows 10 with LV 2017


Edited by JKI-OfAllTrades
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.